A planned maintenance activity for the HID Admin Portal Service and Self Service Portal has been completed.
Many Thanks HID Authentication Service.
Posted Aug 06, 2026 - 03:00 UTC
In progress
The planned scheduled maintenance activity for the HID Admin Portal Service and Self Service Portal has begun.
DURATION The maintenance window for this activity is planned from 02:30 AM UTC and 03:30 AM UTC on Thursday, August06, 2026.
REGIONS AFFECTED EU - Ireland NA - North America
IMPACT During this maintenance period, no service degradation is expected.
Many Thanks HID Authentication Service Team.
Posted Aug 06, 2026 - 02:35 UTC
Scheduled
A maintenance activity is scheduled for Thursday, August06, 2026, starting at 02:30 AM UTC in order to deploy a new release of the HID Admin Portal Service and Self Service Portal.
DURATION The maintenance window for this activity is planned between 02:30 AM UTC and 03:30 AM UTC
REGIONS AFFECTED EU - Ireland NA - North America
IMPACT During this maintenance period, no service degradation is expected
Many thanks HID Authentication Service Team
Posted Aug 05, 2026 - 09:39 UTC
This scheduled maintenance affected: Europe West (EU) (Admin Portal, Self Service Portal) and America (NA) (Admin Portal, Self Service Portal).