Key Migration activity for the HID Authentication Service has been completed.
Many Thanks HID Authentication Service.
Posted Mar 20, 2025 - 11:33 UTC
Scheduled
Upcoming Key Migration for the HID Authentication Service
As part of HID's ongoing commitment to security best practices, we will soon be upgrading the tenant OpenID signing and encryption keys from RSA 2048 to RSA 4096-bit key length.
Are there any actions required on your side?
No. Starting March 10th, 2025, your tenant's OpenID keys will automatically upgrade to the larger key type during their regular renewal cycle. These keys will publish to your tenant's JWKS endpoint as normal, with no administrator action required.
Impact on Your Applications
Most applications will handle this change seamlessly without any intervention. However, we recommend testing your applications' compatibility with the larger key length and updating them if needed to avoid any potential service interruptions.
For any technical support questions or queries, please raise a case via our HID Technical Support community, and the team will be in contact to discuss your issue.
REGIONS AFFECTED
Europe East (DE)
Europe West (EU)
America (NA)
Best Regards, The HID Authentication Service Team
Posted Feb 28, 2025 - 04:33 UTC
This scheduled maintenance affected: Europe East (DE) (SCIM API, OpenID API), Europe West (EU) (SCIM API, OpenID API), and America (NA) (SCIM API, OpenID API).