The DNS resolution degradation affecting the HID Authentication Service was resolved yesterday following a brief period of degraded service for some customers. Since our last update, we have been continuously monitoring DNS resolution performance of domain resolution and no further occurrences of the issue have been observed.
We are closing this incident; however, we will continue to monitor DNS resolution as a precaution. Should any further degradation be detected, we will provide an update accordingly.
Many Thanks. HID Authentication Service team
Posted Apr 09, 2026 - 10:57 UTC
Update
Hi,
We are actively investigating the degraded DNS resolution affecting the HID Authentication Service. This degradation is caused by DNS infrastructure impacts outside of the HID Authentication Service environment.
We are working directly with our DNS provider to validate if they are experiencing any upstream issues affecting the HIDglobal.com domain. At present, we are observing an improvement in DNS resolution; however, we are awaiting confirmation from our provider on the root cause of the degradation and whether the current improvement is sustained. We will provide a further update once this has been confirmed.
Many Thanks. HID Authentication Service team
Posted Apr 08, 2026 - 11:37 UTC
Investigating
Hi,
We are currently observing degraded DNS resolution affecting the HID Authentication Service. This is caused by DNS infrastructure impacts outside of the HID Authentication Service environment. Our teams are actively monitoring the situation and working with the relevant providers to restore full resolution performance. We will provide updates as further information becomes available.
Many Thanks. HID Authentication Service team
Posted Apr 08, 2026 - 10:52 UTC
This incident affected: Europe East (DE) (SCIM API, OpenID API), Europe West (EU) (SCIM API, OpenID API), and America (NA) (SCIM API, OpenID API).